Home » Support » Knowledge Base » Knowledge Base

Knowledge Base

Pro Tools M-Powered 7.4, compatible M-Audio devices and drivers
Text size [-] [+]

The following select M-Audio interfaces below are qualified for use with Pro Tools M-Powered 7.4:

Windows XP and Mac OS X*:

- Audiophile USB
- Black Box
- Conectiv
- Delta 1010
- Delta 1010LT
- Delta 66
- Delta 44
- Delta Audiophile 192
- Delta Audiophile 2496
- Fast Track Pro
- Fast Track USB
- Fast Track Ultra
- Fast Track Ultra 8R
- FireWire 410
- FireWire 1814
- FireWire Audiophile
- FireWire Ozonic
- FireWire Solo
- JamLab
- KeyStudio 49i
- MobilePre USB
- MobilePre Academic
- NRV10
- Ozone
- Ozone Academic
- ProFire Lightbridge
- ProFire 2626**
- ProjectMix I/O
- Transit
- Xponent


Windows Vista (32 bit):

- Audiophile USB
- Black Box
- Conectiv
- Delta 1010
- Delta 1010LT
- Delta 66
- Delta 44
- Delta Audiophile 192
- Delta Audiophile 24/96
- Fast Track USB
- Fast Track Pro
- Fast Track Ultra
- Fast Track Ultra 8R
- FireWire 410
- FireWire 1814
- FireWire Audiophile
- FireWire Ozonic
- FireWire Solo
- JamLab
- KeyStudio 49i
- NRV10
- ProFire Lightbridge
- ProFire 2626
- ProjectMix I/O
- Xponent

Pro Tools M-Powered requires that the latest QUALIFIED M-Audio device driver be installed on your system in order to recognize certain interfaces. Please check the release notes for your selected driver to ensure that it is qualified for use with Pro Tools M-Powered 7.4. As soon as more products and drivers are qualified for use with Pro Tools M-Powered 7.4, this FAQ and the release notes for the associated drivers will be immediately updated to reflect this.

If your compatible M-Audio device is properly installed, but Pro Tools M-Powered will not launch because "no compatible hardware" is found, you may be using a driver version that pre-dates Pro Tools M-Powered 7.4 compatibility. The latest M-Audio drivers can be found on our drivers download page.  Pro Tools M-Powered 7.4cs3 or higher is required for Fast Track Ultra, Fast Track Ultra 8R, and ProFire 2626.

The Pro Tools M-Powered 7.4 upgrade can be purchased directly from M-Audio. Click to visit the web store.


* Please note that Pro Tools M-Powered 7.4.2 is required for compatibility with Mac OS X 10.5 Leopard. Please note that Pro Tools 7.4.2 is compatible with Mac OS X 10.5.3, and not earlier versions of Leopard.

** The driver for the ProFire 2626 on OS X 10.4 Tiger is only supported on OS X 10.4.11; although Mac OS X 10.4.11 has not been tested or qualified by Digidesign, the only known issue at this time has to do with Pro Tools failure to launch in some cases due to improper prebinding. Please reference Digidesign’s
compatibility page for more information.